Object is sent to state 0 whenever a text scene loads

For problems with creating games or for reporting bugs of the Tool.
Rohan
PaC-DK Newby
Posts: 37
Joined: 23 Apr 2008, 18:45
Location: Mifflin Pa
Contact:

Object is sent to state 0 whenever a text scene loads

Post: #78673 Rohan
17 Oct 2011, 07:39

Have yet another problem before I solved the first. I have an object (Characters mouth) where if you click on another object (a talk button) the characters mouth goes to state 1 and then a text scene loads. The script looks like this:

On(click)
{
Instobj(TalkingMouth; 1)
textscene(conversation ; 10 ; 635 ; 500)
}

As soon as the text scene starts the talkingmouth obj disapears...
I'm trying to prevent the object from disappearing when the text scene starts; I'm not looking for an alternative for making my character talk like including the mouth as part of the character. I want the mouth to be an object separate from the character.

User avatar
Zimond
Der Engine Papa
Posts: 3303
Joined: 06 Apr 2003, 19:34
Location: Krefeld
Contact:

Re: Object is sent to state 0 whenever a text scene loads

Post: #78675 Zimond
17 Oct 2011, 15:31

I guess you put your mouth object into the anywhere room? This room is always hidden when you start a textscene.

If you insist on your method (which i actually cannot understand..) the only way, if i am not mistaken, is to add your mouthobject to EVERY room your character walks in. You can use a string to make it more easy to use.

Roomscript :

on (enter)
{
setstring (talkingmouth ; mouth023) .. or mouth025, mouth026 ect
}


With that you can still use your talkingmouth with the same instructions : instobj ([Talkingmouth] ; 1)
Image

Rohan
PaC-DK Newby
Posts: 37
Joined: 23 Apr 2008, 18:45
Location: Mifflin Pa
Contact:

Re: Object is sent to state 0 whenever a text scene loads

Post: #78680 Rohan
19 Oct 2011, 02:55

Haha, I don't think I explained that right. Actually its a character that only appears once and doesn't walk, all he does is talk using offspeech so he's not really a "character" in the technical sense. I didn't put the talkingmouth in a subroom, all three of the components the character is composed of are in the same room so it doesn't make sense that the mouth would dissapear and not the rest of the body. I don't know why I didn't think about this, but maybe what I should do is recreate the talkingmouth since its the only object in the room that seems to have trouble during a text scene. Its probably because I spent 5 hours that day working on my game and my brain got fried :doh:

User avatar
japanhonk
PaC-DK God
Posts: 1639
Joined: 05 Feb 2009, 20:36
Location: NRW
Contact:

Re: Object is sent to state 0 whenever a text scene loads

Post: #78681 japanhonk
19 Oct 2011, 06:48

Did you try to set the talkingmouth object to state 1 inside or directly before starting the textscene ?
Maybe you could try using a minicut () before.

What happens if you set the state to 1 via console during the game ?
Does the object change to 1 or not ?
If not, I think there is any scriptline placed to set the object back to 0.
I searched for such a problem 6 days until I found a line into an object animation scriptline.
So what scriptline set it back to 0 after the textscene is over ?
You could remove that line for testing... :mmh:
Es gibt 10 Arten von Usern :
die, die Binärcode verstehen und die, die es nicht tun....
----------------------------------------------------------
STAR TREK FYNE :
http://www.fynegames.homepage.t-online.de

User avatar
Zimond
Der Engine Papa
Posts: 3303
Joined: 06 Apr 2003, 19:34
Location: Krefeld
Contact:

Re: Object is sent to state 0 whenever a text scene loads

Post: #78683 Zimond
19 Oct 2011, 22:37

if all objects are placed in the subroom it might be an order problem.
Image


Return to “Problems and Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest