Playvideo in cutscene oder miniscene bricht restliches Gespräch ab

Das Board für Schwierigkeiten beim Adventure-Machen und zum Melden von Bugs
NoFear13
PaC-DK Newby
Posts: 6
Joined: 26 Mar 2017, 16:26

Playvideo in cutscene oder miniscene bricht restliches Gespräch ab

Post: #83641 NoFear13
31 Mar 2017, 21:46

Hi zusammen,

hab wieder mal ein Problemchen, wenn ich in einer miniscene oder cutscene ein Video spiele bricht das restliche Gespräch ab:

Code: Select all


on(click)
{
 minicut()
 {
 offspeech(13;12;Hey wie geht's?)
 speech(Victoria; Ganz gut, sieh mal hier:)
 playvideo(VictoriaZeigtBuch; true)
 offspeech(13;12;Ein tolles Buch!)
 //...restlicher Code
 }
}



Hab dass dann auf cutscene umgebaut und auch hier bricht das Gespräch nach dem Video ab, in textscene funktioniert der gleiche Code, das Video spielt und das Gespräch geht normal weiter. Ich wollte an dieser Stelle jetzt aber kein textscene machen mit einer Option, habe ich jetzt aber erst mal so umgebaut, und siehe da alles funktioniert wie gewünscht.

Wollte nur darüber informieren fühlt sich für mich irgendwie nach einem Bug an!

Oder mache ich wieder was falsch, glaube ich allerdings nicht, da der gleiche Code in textscene funktioniert.

Vielen Dank
NoFear13

User avatar
Zimond
Der Engine Papa
Posts: 3303
Joined: 06 Apr 2003, 19:34
Location: Krefeld
Contact:

Re: Playvideo in cutscene oder miniscene bricht restliches Gespräch ab

Post: #83642 Zimond
01 Apr 2017, 15:10

Videos stehen immer außen vor. Du kannst sie nicht mit anderen Spielinhalten mischen. Für Videos werden Windows eigenes Mediaplayergedöns verwendet, die eigentliche Engine tritt dann in den Hintergrund. Du müsstest deinen Offspeech also direkt ins Video einbauen.
Image

NoFear13
PaC-DK Newby
Posts: 6
Joined: 26 Mar 2017, 16:26

Re: Playvideo in cutscene oder miniscene bricht restliches Gespräch ab

Post: #83643 NoFear13
01 Apr 2017, 17:44

Danke für die Info, heißt dass es könnte in einer zukünftigen Version sein, dass das auch in textscene nicht mehr funktioniert, wie gesagt, hier funktioniert alles wie geplant und das Video kommt zwischen den offspeech?

Vielen Dank für deine Hilfe.


Return to “Probleme und Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest